Raspberry Pi 2 + CentOS7でSnortを使う

Raspberry Pi 2向けCentOS7にSnortを入れた時の備忘録。

CentOS7が最小構成なので色々と足りないものがあり、普通にSnortをインストールしようとすると途中でコケます。

エラーが出るたびに足りないものをインストールするのは面倒なので必要なものを纏めました。

足りないものリストを以下に示します。

  • make
  • Libcap
  • Libpcre
  • Libdnet
  • zlib

追記

以下ではLibcap、Libpcre、Libdnetをクロスコンパイルしていますが、yumにarmv7hlのパッケージがあったので、以下で全ての準備が整いそうです(未検証)。

[root@rpi2 ~]$ yum install libcap libcap-devel pcre pcre-devel libdnet libdnet-devel zlib zlib-devel
[root@rpi2 ~]$ yum groupinstall "Development Tools"

makeのインストール

bash: make: command not found なのでmakeが無いみたい。

コンパイルに必要そうなものを纏めてインストールします。

[root@rpi2 ~]$ yum groupinstall "Development Tools"

Libcapのインストール

Libcapの最新バージョンを確認してダウンロードします。

[root@rpi2 ~]$ wget http://www.tcpdump.org/release/libpcap-1.7.4.tar.gz
[root@rpi2 ~]$ tar xvzf libpcap-1.7.4.tar.gz
[root@rpi2 ~]$ cd libpcap-1.7.4/
[root@rpi2 libpcap-1.7.4]$ ./configure
[root@rpi2 libpcap-1.7.4]$ make
[root@rpi2 libpcap-1.7.4]$ make install

インストールされたことを確認します。

[root@rpi2 libpcap-1.7.4]$ ls /usr/local/lib/libpcap.*
/usr/local/lib/libpcap.a   /usr/local/lib/libpcap.so.1
/usr/local/lib/libpcap.so  /usr/local/lib/libpcap.so.1.7.4

Libpcreのインストール

Libpcreの最新バージョンはpcre2-10.20でしたが、pcre2は必要とされていないのでpcre-8.37をインストールします。

[root@rpi2 ~]$ wget ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/pcre-8.37.tar.gz
[root@rpi2 ~]$ tar xvfz pcre-8.37.tar.gz
[root@rpi2 ~]$ cd pcre-8.37
[root@rpi2 pcre-8.37]$ ./configure
[root@rpi2 pcre-8.37]$ make
[root@rpi2 pcre-8.37]$ make install

インストールされたことを確認します。

[root@rpi2 pcre-8.37]$ ls /usr/local/include/pcre.h
/usr/local/include/pcre.h

Libdnetのインストール

Libdnetをインストールします。

[root@rpi2 ~]$ wget http://libdnet.googlecode.com/files/libdnet-1.12.tgz
[root@rpi2 ~]$ tar xvfz libdnet-1.12.tgz
[root@rpi2 ~]$ cd libdnet-1.12
[root@rpi2 libdnet-1.12]$ ./configure
[root@rpi2 libdnet-1.12]$ make
[root@rpi2 libdnet-1.12]$ make install

インストールされたことを確認します。

[root@rpi2 libdnet-1.12]$ ls /usr/local/include/dnet.h
/usr/local/include/dnet.h

zlibのインストール

zlibのヘッダーが無いようなので、zlib-develを入れます。

[root@rpi2 ~]$ yum install zlib-devel

Snortのインストール

Get Startedに従って進めれば良いでしょう。

お疲れ様でした!

 

コメントを残す

*

次のHTML タグと属性が使えます: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>